BLOGTIMES
2012/06/01

バージョン指定で gem を使う

  ruby 
このエントリーをはてなブックマークに追加

gem で何か理由があって最新版以外のものを使いたいときには、下記のようにバージョンを指定してインストールことができます。

gem install -v 2.4.0

ところが、複数のバージョンの gem が導入されているときにそれを選択する方法がわからなくて困ったのでメモ。
こんな感じで gem というメソッドを使えばいいんですね。

require 'rubygems' gem 'mail', '2.4.0' require 'mail'

    トラックバックについて
    Trackback URL:
    お気軽にどうぞ。トラックバック前にポリシーをお読みください。[policy]
    このエントリへのTrackbackにはこのURLが必要です→https://blog.cles.jp/item/4987
    Trackbacks
    このエントリにトラックバックはありません
    Comments
    愛のあるツッコミをお気軽にどうぞ。[policy]
    古いエントリについてはコメント制御しているため、即時に反映されないことがあります。
    コメントはありません
    Comments Form

    コメントは承認後の表示となります。
    OpenIDでログインすると、即時に公開されます。

    OpenID を使ってログインすることができます。

    Identity URL: Yahoo! JAPAN IDでログイン