NP_cles()

12345678910111213141516171819202122232425262728293031

NP_Moblog v1.10

 
投稿者:hsur 投稿日時:2005-10-03 - 01:30
カテゴリー:Plug-in - - トラックバック(default)- Views: 24
NP_Moblog設定 - NP_Moblog v1.10

まむろぐさんのえんとりで言及されている、添付ファイルがある場合にのみエントリを追加するように設定している場合に、エントリが正常に追加されないバグをFixしたv1.10をリリースします。

v1.8以下からのアップグレードには一旦旧版のアンインストールが必要です。アンインストール時には設定が消失しますので、必ず設定のメモを必ず取ってください。(※NP_RetainOptionsを使っている場合には「Nucleusカテゴリ名(Blog名)」の更新のみで大丈夫だと思います。

ダウンロードはこちら [NP_Moblog v1.10][508clicks]
Bugfix版のNP_Moblog v1.11をリリースしています。

動作確認はNucleus 3.21(UTF-8)、PHP 4.4.0環境で行っています。
動作確認報告、バグ報告はこのエントリへ、コメント・トラックバックをお願いします。

変更点

[Fixed] 「イメージ添付メールのみ追加?」が「はい」の場合に、添付ファイルが存在しているにもかかわらず、エントリが追加されない不具合を修正

私のポカミスで判定条件が正反対に設定されていました。お恥ずかしい。。。。。

[Added] 管理画面から動作確認ができる機能を追加

プラグイン管理画面の「管理」より、動作確認の報告+バグ報告ができるようになりました。
コメントやトラックバックをするのはちょっと・・・という方はこちらからフィードバックを送っていただければと思います。プライバシーに関連するデータは収集していませんのでご安心を。

管理画面 - NP_Moblog v1.10

    このエントリは役に立ちましたか?

      

    トラックバックについて [policy]

    Trackback URL:
    Trackbacks
    ヘルプ(プラグイン管理ページから参照可)に「はじめてお使いになる方はオプションの多さにビックリされているかもしれません。」とある通りに、びっくりしましたが(笑)、そのヘルプがとっても丁寧に書かれているので安心です。 ...
    Nucleusの各種プラグインを紹介するblog (2005/10/31 00:12)

    Comments [policy]

    wata wrote:

    はじめまして、いつも活用させて頂いております。
    v1.9をUFT-8をEUCにしてインストールしたのですが、文字化けがおこります。
    確認しているもので、店、年度、などがあります。

    参照ページ
    http://www.genki1.net/yuri/
    また、v1.10にバージョンアップしたブログでは、
    タイトルと本文が、店(一文字)の場合文字化けします。
    参照ページ
    http://www.gluee.jp/blog/

    Nucleusはv3.21です。
    何か原因となりそうなものはあるでしょうか?
    お手数ですが、よろしくお願いします。

    2005-10-08 14:52 <%HatenaAuth()%> 

    hsur wrote:

    wataさん

    日本語処理部分は文字コードの自動認識をかけているので、本文やSubjectが極端に短い場合にはそれがうまくいかずに文字化けしてしまうかもしれません。
    # NP_Moblog自体はSubjectやBodyが一文字である状況をあまり想定していませんので。

    とりあえず、ちょっと文字列周りの部分をチェックしてみますね。

    2005-10-08 22:14 <%HatenaAuth()%> 

    wata wrote:

    管理人様

    お世話になります。
    ご返答ありがとうございます。

    先日は、一文字の場合文字化けすると言いましたが、特定の文字列でも文字化けすることが確認できました。

    以下ブログの、最初の記事、
    2005Cは、2005年度メンバー紹介
    その次の、
    2005曙キは、2005年度練習スケジュール
    と、本来の文字列から化けています。

    また、サイドメニューのカテゴリー欄のところの空白は、「全てのカテゴリの表示」が、「Y」に化けてしまっているため、起こっています。
    テンプレートを編集しても、化けてしまいます。

    参照サイト
    http://www.genki1.net/niceh...

    お手数ですが、何か原因らしきものがわかりましたら、教えてくださいますでしょうか。

    よろしくお願いします。

    2005-10-11 13:30 <%HatenaAuth()%> 

    hsur wrote:

    wataさん

    情報ありがとうございます。
    こちらでも同様のテストをしてみますね。

    ちなみにメールは何から投稿されてますか?
    # ケータイであればキャリア名とか、端末の機種名を教えていただけると助かります。

    2005-10-11 13:53 <%HatenaAuth()%> 

    wata wrote:

    管理人様

    お世話になります。
    ご返答ありがとうございます。

    メールはOutlookからと、携帯は
    Docomoのpremini-IIS
    http://www.sonyericsson.co....
    です。

    が、先ほどメールでの投稿では文字化けしないことが判明致しました。

    文字化けするのは、
    ①ブラウザ(IE)からアイテムを追加した場合。
    ②携帯からの投稿を編集した場合。
    と、現状では判断できます。

    よって、Moblogが文字化けの原因ではないかもしれません。
    Moblogが原因だと判断した経緯として、最近になり、メインで動かしているNucleusが文字化けを起こしました。
    原因を探るために、文字化けが起こった時期に入れたプラグインを、別のNucleusに試していたところ、Moblog v1.9で、メインのブログと同様の文字化けが起こりましたので、そう判断した次第です。

    大変お手数ですが、Moblogが原因かどうか、以上の情報でご判断が出来るようでしたら、お願い致します。

    2005-10-11 15:57 <%HatenaAuth()%> 

    hsur wrote:

    wataさん

    NP_Moblogが関連するのは、メールからエントリを追加する場合(下書きを含む)のみです。ここまでで文字化けが発生していないようであれば、NP_Moblogと今回の問題は関係がないのではないかと思います。

    文字化けが発生している「ブラウザ(IE)からアイテムを追加した場合」や「携帯からの投稿を編集した場合」はどちらもPCからの投稿・編集にあたるので、NP_Moblogは全く関与していないです。

    # MySQLやPHP周りの設定を疑った方がいいかもしれませんね。

    2005-10-11 16:11 <%HatenaAuth()%> 

    wata wrote:

    管理人様

    お世話になります。
    ご返答ありがとうございます。

    NP_Moblogと今回の問題は関係がないのではないかと思います。

    了解致しました。
    ご迷惑をおかけして、大変申し訳ありませんでした。

    # MySQLやPHP周りの設定を疑った方がいいかもしれませんね。

    ご助言ありがとうございます。
    そのあたりを探ってみたいと思います。

    最後に、色々お手数をお掛けしました。
    ご親切な対応ありがとうございます。
    失礼します。

    2005-10-11 18:25 <%HatenaAuth()%> 

    hsur wrote:

    wataさん

    そんなに恐縮されなくても結構ですよ。
    また、何かあったら気軽に書き込んでくださいね。

    2005-10-11 18:41 <%HatenaAuth()%> 

    むう wrote:

    こんにちは、『まむろぐ』のむうです。
    1.10にアップデートして携帯投稿を試した所、問題なく動作しております。
    NP_Moblogは旅行時などの時の更新に大変重宝しております、これからもどうぞ宜しくお願いします。

    それから、先日アイテム番号を振り直しした為、記事内で紹介して頂いているアイテムへのリンク先が他のアイテムへのリンクとなっております。
    差し支えなければお手数ですが、81から700へ修正をお願い致します。

    2005-10-16 17:35 <%HatenaAuth()%> 

    hsur wrote:

    むうさん

    いえいえ。恥ずかしいバグでもうしわけないです。アイテムNoの件の修正もしておきました。

    2005-10-17 03:08 <%HatenaAuth()%> 

    takab wrote:

    はじめまして。NP_Moblog使わせていただいております。
    help.htmlですが、
    line1: <img border="0" src="http://blog.cles.jp/cles.png" alt="Powered by CLES"/ >
    ...alt="Powered by CLES" />
    としないとブラウザによってはパースエラーを吐きます。
    同様にline61:...@b=2&c=books&s=1
    の"&"も&amp;にしないとパースエラーを吐くブラウザがあります。

    細かいことになりますが、とりあえずご報告いたします。

    2005-11-17 02:03 <%HatenaAuth()%> 

    hsur wrote:

    takabさん

    ありがとうございます。
    次回リリースから修正しますね。

    2005-11-17 09:57 <%HatenaAuth()%> 

    kazupon wrote:

    初めましてNP_Moblog利用させて頂いております

    help.htmlのスキンへの記述タグとして紹介されてる<%Moblog(list)%>ですが、実際は<%Moblog(link)%>のようです

    2005-12-06 14:10 <%HatenaAuth()%> 

    hsur wrote:

    kazuponさん

    ご指摘ありがとうございます。
    そのとおりですね。
    次回リリースから修正しますね。

    2005-12-06 14:48 <%HatenaAuth()%> 

    takab wrote:

    二度目のコメントになります。takabです。

    Pearへの依存に関してですが、他にPearに依存するプラグインが出てきた場合、おそらくCannot redeclare エラーを吐くことになるのではないでしょうか?
    競合のチェックするか、どこかにpear用ディレクトリを作ってinclude_path を設定してやったほうが良いのではと思うのですが、いかがでしょう?

    2005-12-27 12:47 <%HatenaAuth()%> 

    hsur wrote:

    takabさん

    ありがとうございます。takabさんがおっしゃることは良くわかります。
    include_pathを設定するのがPEARの本来の姿であるとは思うのですが、設定が面倒になるのはどうなのかと思って今の形に落ち着きました。改善の余地があることはわかっているので、もうすこし僕のほうでも工夫してみます。

    # 当初はどんなサーバでもPEARくらいはインストールしてあるだろうと思ったのですが、
    # 見事にあてがはずれました。

    実は今開発しているNP_TypeKeyでPEARを使ったところCannot redeclareが発生してしまったので、
    if( class_exists('HOGE') )
    のようにして当面はしのぐことにしました。

    2005-12-27 13:09 <%HatenaAuth()%> 

    takab wrote:

    お返事ありがとうございます。
    外部ライブラリ用にpathを通すとかは本家へ投げるべきカナとは思ったのですが。

    NP_Pear とかが美しい方法なんでしょうが、プラグインが増えるのはみんないや?
    init() でpathを通したり、依存関係チェックとか、インストールまでやってくれたり。

    2005-12-27 13:19 <%HatenaAuth()%> 

    Add Comments

    コメントは承認後の表示となります。
    OpenIDでログインすると、即時に公開されます。

    OpenID を使ってログインすることができます。

    Identity URL: Yahoo! JAPAN IDでログイン