BLOGTIMES
2020/08/31

docker を dnf でインストールするときに --nobest をつけなくてすむようにする

  docker  centos8 
このエントリーをはてなブックマークに追加

以前、CentOS 8 に docker-compose をインストールしたときに、--nobest で入れてしまったので、その後もアップデートの度に --nobest をつける必要があって困っていたのですが、やっと解決方法が分かったのでメモ。

例えば --nobest をつけないで dnf update するとこんな感じのエラーを吐きます。
containerd.io の問題であることが分かります。

$ sudo dnf update メタデータの期限切れの最終確認: 0:05:32 時間前の 2020年08月31日 15時06分14秒 に実施しました。 エラー: 問題: package docker-ce-3:19.03.12-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed - cannot install the best update candidate for package docker-ce-3:18.09.1-3.el7.x86_64 - package containerd.io-1.2.10-3.2.el7.x86_64 is filtered out by modular filtering - package containerd.io-1.2.13-3.1.el7.x86_64 is filtered out by modular filtering - package containerd.io-1.2.13-3.2.el7.x86_64 is filtered out by modular filtering - package containerd.io-1.2.2-3.3.el7.x86_64 is filtered out by modular filtering - package containerd.io-1.2.2-3.el7.x86_64 is filtered out by modular filtering - package containerd.io-1.2.4-3.1.el7.x86_64 is filtered out by modular filtering - package containerd.io-1.2.5-3.1.el7.x86_64 is filtered out by modular filtering - package containerd.io-1.2.6-3.3.el7.x86_64 is filtered out by modular filtering (インストール不可のパッケージをスキップするには、'--skip-broken' を追加してみてください または、'--nobest' を追加して、最適候補のパッケージのみを使用しないでください)

ここで、問題の containerd.io を以下のコマンドで手動でインストールしてやるとエラーを解消することができます。

yum install -y https://download.docker.com/linux/centos/7/x86_64/stable/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm

参考


    トラックバックについて
    Trackback URL:
    お気軽にどうぞ。トラックバック前にポリシーをお読みください。[policy]
    このエントリへのTrackbackにはこのURLが必要です→https://blog.cles.jp/item/11945
    Trackbacks
    このエントリにトラックバックはありません
    Comments
    愛のあるツッコミをお気軽にどうぞ。[policy]
    古いエントリについてはコメント制御しているため、即時に反映されないことがあります。
    コメントはありません
    Comments Form

    OpenID を使ってログインすることができます。

    Identity URL: Yahoo! JAPAN IDでログイン