BLOGTIMES
2009/03/10

yumで特定のパッケージが更新されないようにする

  linux 
このエントリーをはてなブックマークに追加

自分のサーバのproftpdのrpmはnlst対策用のパッチが入っている自作のバージョンなので、yumで他のパッケージをアップデートするときに勝手にアップデートされると困るのですが、いつも間違ってアップデートしてしまいそうになるのでyumで特定のパッケージが更新しないようにするオプションを調べてみました。

具体的には/etc/yum.confの[main]セクションに下記の行を追加すればよいようです。

exclude=proftpd*

これでproftpd関連のrpmはyum updateを実行してもリストに表示されないようになります。

参考

@IT:yumで自動更新しないパッケージを指定するには


    トラックバックについて
    Trackback URL:
    お気軽にどうぞ。トラックバック前にポリシーをお読みください。[policy]
    このエントリへのTrackbackにはこのURLが必要です→https://blog.cles.jp/item/2959
    Trackbacks
    このエントリにトラックバックはありません
    Comments
    愛のあるツッコミをお気軽にどうぞ。[policy]
    古いエントリについてはコメント制御しているため、即時に反映されないことがあります。
    コメントはありません
    Comments Form

    コメントは承認後の表示となります。
    OpenIDでログインすると、即時に公開されます。

    OpenID を使ってログインすることができます。

    Identity URL: Yahoo! JAPAN IDでログイン