BLOGTIMES
2015/09/05

ASUS のマザボで MegaRAID 9341-4i/8i を使ってはいけない

  megaraid  asus  sas 
このエントリーをはてなブックマークに追加

Windows 8.1*1 や 10 へのアップグレードでもさんざん邪魔をしてくれた LSI (Avago) MegaRAID SAS 9341-4i*2ですが、とうとう致命的な欠陥があるという確証を持つに至ったので構成から取り外すことにしました

このカード、なぜかファームウェアをアップグレードすると Windows 上のドライバが「このデバイスを開始できません(コード10)」というエラーを出して動かないという問題があり、また I/O に一杯に負荷をかけるとオーバークロックしていなくてもマシンが落ちてしまう(しかもメモリ関連のエラーが出るけど、メモリチェックしても問題は検出されない)という安定性の問題もあって、常々怪しいと思っていました。

今回の Windows 10 へのアップグレードを機に改めて調べ直してみると、ASUS のマザボだと動かないという症例が出るわ出るわ。

で、一番クリティカルヒットだったのは英語のフォーラムの以下の書き込み。
マザボの問題でワークアラウンドがない上に、サポートしてないマザボも多いよという致命的な話でした。

LSI 9341-8i SAS-SATA Raid card, Driver fails to start in Windows 7 64Bit.

I am having the same problem on my Dell T7600. This is the reply that I received from LSI:
=============================================
The 9341-4i and -8i are software raid controllers. It has to be able to allocate memory during boot up or the driver will not initialize. The system board must support Interrupt 15 (memory allocation). Many desktop and workstation boards do not support INT15. There is no workaround it

The better option is use a hardware raid model 9361-4i or -8i
=============================================

どうやら僕の Z87-DELUXE もこの対象に入っているようです。

これ以上足掻いても仕方がないので、古いカードですが 3ware 9650SE-2LP に出戻り することにしました。ちゃんとファームウェアを最新版にしたら 8TB のディスクも問題なく認識してくれて、今までの不調が嘘のようです。そもそもそれほど速度が出るディスクでもないのでしばらくはこれで頑張ってしまうつもりです。3ware も今は Avago になっていますが、3ware 時代のプロダクトの方がずっと優秀だったと思うのは僕だけでしょうか。


トラックバックについて
Trackback URL:
お気軽にどうぞ。トラックバック前にポリシーをお読みください。[policy]
このエントリへのTrackbackにはこのURLが必要です→https://blog.cles.jp/item/7870
Trackbacks
このエントリにトラックバックはありません
Comments
愛のあるツッコミをお気軽にどうぞ。[policy]
古いエントリについてはコメント制御しているため、即時に反映されないことがあります。
コメントはありません
Comments Form

コメントは承認後の表示となります。
OpenIDでログインすると、即時に公開されます。

OpenID を使ってログインすることができます。

Identity URL: Yahoo! JAPAN IDでログイン